From 358925ec028bcdb312616ffebf427eda595896cd Mon Sep 17 00:00:00 2001
From: Gulliver <gulliver@fargonauten.de>
Date: Wed, 10 Sep 2014 14:08:44 +0200
Subject: added initial version of cmake build-files

---
 src/CMakeLists.txt | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)
 create mode 100644 src/CMakeLists.txt

(limited to 'src/CMakeLists.txt')

diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..c454eca
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,34 @@
+set(PROGRAM_stmd "stmd")
+set(PROGRAM_stmd_SOURCES blocks.c
+inlines.c
+main.c
+debug.h
+detab.c
+bstrlib.c
+bstrlib.h
+getopt.c
+html.c
+
+
+print.c
+scanners.h
+scanners.re
+stmd.h
+utf8.c
+utf8.h
+uthash.h 
+)
+
+add_executable(${PROGRAM_stmd} 
+                ${PROGRAM_stmd_SOURCES})
+
+if (MSVC)
+set_property(TARGET ${PROGRAM_chronolog} 
+					 APPEND PROPERTY LINK_FLAGS /INCREMENTAL:NO) 
+target_link_libraries(${PROGRAM_chronolog} gdiplus.lib)
+endif(MSVC)
+install(TARGETS ${PROGRAM_chronolog}
+RUNTIME DESTINATION bin 
+BUNDLE DESTINATION Applications)
+
+
-- 
cgit v1.2.3